请选择 进入手机版 | 继续访问电脑版

易语言吧

 找回密码
 立即注册

搜索
热搜: 活动 交友 discuz
查看: 1815|回复: 7

[易语言问题] 独立编译时文件读入失败

[复制链接]

3

主题

9

帖子

36

积分

初识易语言

Rank: 1

积分
36
威望
0
易币
27
贡献
0
积分
36
UID
661
在线时间
2 小时
注册时间
2019-12-12
发表于 2019-12-14 23:43:40 | 显示全部楼层 |阅读模式
1易币
按照课程自己做了一个软件,编译时出现了问题,请大佬帮忙看一下怎么解决
QQ截图20191214233948.png
QQ截图20191214233956.png

这是我的代码:

.版本 2

.子程序 _时钟1_周期事件
.局部变量 欲查询句柄, 整数型
.局部变量 信息, RECT

欲查询句柄 = API_寻找顶级窗口 (编辑框1.内容, 编辑框2.内容)
标签2.标题 = 到文本 (欲查询句柄)

API_取窗口矩形 (欲查询句柄, 信息)
标签3.标题 = 到文本 (信息.顶边)
标签4.标题 = 到文本 (信息.底边)
标签6.标题 = 到文本 (信息.左边)
标签5.标题 = 到文本 (信息.右边)



.子程序 _按钮1_被单击

时钟1.时钟周期 = 100
按钮1.标题 = “刷新中”
.如果 (编辑框1.内容 = “”)
    信息框 (“请输入窗口类名”, 0, , )
    编辑框1.获取焦点 ()
    返回 ()

.否则
    .如果 (编辑框2.内容 = “”)
        信息框 (“请输入窗口标题”, 0, , )
        编辑框2.获取焦点 ()
        返回 ()

    .否则

    .如果结束

.如果结束


.子程序 _按钮2_被单击

时钟1.时钟周期 = 0
按钮1.标题 = “刷新”

.子程序 __启动窗口_创建完毕

标签2.标题 = “等待载入”
标签3.标题 = “等待载入”
标签4.标题 = “等待载入”
标签6.标题 = “等待载入”
标签5.标题 = “等待载入”


3

主题

9

帖子

36

积分

初识易语言

Rank: 1

积分
36
威望
0
易币
27
贡献
0
积分
36
UID
661
在线时间
2 小时
注册时间
2019-12-12
 楼主| 发表于 2019-12-15 00:05:05 | 显示全部楼层
找了半天没找到编辑帖子的地方
不知道怎么修改帖子,刚才发现代码中的BUG,修改了一下


.版本 2


.子程序 _时钟1_周期事件
.局部变量 欲查询句柄, 整数型
.局部变量 信息, RECT


欲查询句柄 = API_寻找顶级窗口 (编辑框1.内容, 编辑框2.内容)
标签2.标题 = 到文本 (欲查询句柄)


API_取窗口矩形 (欲查询句柄, 信息)
标签3.标题 = 到文本 (信息.顶边)
标签4.标题 = 到文本 (信息.底边)
标签6.标题 = 到文本 (信息.左边)
标签5.标题 = 到文本 (信息.右边)






.子程序 _按钮1_被单击


时钟1.时钟周期 = 100


.如果真 (编辑框1.内容 = “”)
    信息框 (“请输入窗口类名”, 0, , )
    编辑框1.获取焦点 ()
    返回 ()


.如果真结束


.如果真 (编辑框2.内容 = “”)
    信息框 (“请输入窗口标题”, 0, , )
    编辑框2.获取焦点 ()
    返回 ()


.如果真结束




.如果真 (编辑框1.内容 ≠ “” 且 编辑框2.内容 ≠ “”)
    按钮1.标题 = “刷新中”
    编辑框1.禁止 = 真
    编辑框2.禁止 = 真
    返回 ()


.如果真结束


















.子程序 _按钮2_被单击


时钟1.时钟周期 = 0
按钮1.标题 = “刷新”
编辑框1.禁止 = 假
编辑框2.禁止 = 假




.子程序 __启动窗口_创建完毕


标签2.标题 = “等待载入”
标签3.标题 = “等待载入”
标签4.标题 = “等待载入”
标签6.标题 = “等待载入”
标签5.标题 = “等待载入”


回复

使用道具 举报

529

主题

830

帖子

3万

积分

易语言吧管理员

Rank: 9Rank: 9Rank: 9

积分
36503

幽默大师终生成就

威望
0
易币
35273
贡献
0
积分
36503
UID
1
在线时间
1420 小时
注册时间
2019-7-19
发表于 2019-12-15 07:15:52 | 显示全部楼层
截图201912150714109814..png
你好.独立编译提示文件不存在.解决方法是.只勾选箭头带星号的必要文件就行.
而方框内不带星号的文件不用勾选.即可解决
回复

使用道具 举报

3

主题

9

帖子

36

积分

初识易语言

Rank: 1

积分
36
威望
0
易币
27
贡献
0
积分
36
UID
661
在线时间
2 小时
注册时间
2019-12-12
 楼主| 发表于 2019-12-16 19:00:38 | 显示全部楼层
admin 发表于 2019-12-15 07:15
你好.独立编译提示文件不存在.解决方法是.只勾选箭头带星号的必要文件就行.
而方框内不带星号的文件不用勾 ...

试了一下可以了,谢谢大佬
回复

使用道具 举报

0

主题

2373

帖子

9580

积分

VIP超级贵宾

Rank: 8Rank: 8

积分
9580
威望
198
易币
6811
贡献
0
积分
9580
UID
11903
在线时间
35 小时
注册时间
2021-1-23
发表于 2021-5-28 20:49:12 | 显示全部楼层
楼主发贴辛苦了,谢谢楼主分享!我觉得易语言吧是注册对了!
回复

使用道具 举报

0

主题

3

帖子

11

积分

初识易语言

Rank: 1

积分
11
威望
0
易币
8
贡献
0
积分
11
UID
32176
在线时间
0 小时
注册时间
2022-11-24
发表于 2022-11-24 22:15:42 | 显示全部楼层
你写的代码完全没问题,但是你要把你的易语言源代码项目放在C:\Windows\SysWOW64目录下,虽然C:\Windows\System32也有相同的效果,但是由于系统保护,会使该项目源码无法打开或者打开失败
回复

使用道具 举报

0

主题

3

帖子

11

积分

初识易语言

Rank: 1

积分
11
威望
0
易币
8
贡献
0
积分
11
UID
32176
在线时间
0 小时
注册时间
2022-11-24
发表于 2022-11-24 22:19:42 | 显示全部楼层
2037686665 发表于 2022-11-24 22:15
你写的代码完全没问题,但是你要把你的易语言源代码项目放在C:\Windows\SysWOW64目录下,虽然C:\Windows\Sy ...

C:\Users\Administrator\Pictures\这样.png
回复

使用道具 举报

0

主题

3

帖子

11

积分

初识易语言

Rank: 1

积分
11
威望
0
易币
8
贡献
0
积分
11
UID
32176
在线时间
0 小时
注册时间
2022-11-24
发表于 2022-11-24 22:21:34 | 显示全部楼层
就像这样
截图202211242221181970..png
回复

使用道具 举报

懒得打字嘛,点击右侧快捷回复 【选择右侧内容,快速回复】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则 需要先绑定手机号

QQ|一:站内所有资源均来自互联网收集或用户上传分享,本站不拥有此类资源的版权。 作为网络服务提供者,对转载行为的发生不具备充分的监控能力。但是当版权拥有者提出侵权并出示充分的版权证明材料时,易语言吧负有移除转载作品以及停止继续传播的义务。在满足前款条件下采取移除等相应措施后不为此向原发布人承担违约责任,包括不承担因侵权不成立而给原发布人带来损害的赔偿责任。 用户免费分享产生,如果侵犯了你的权益,联系QQ:3066137757|Archiver|手机版|小黑屋|易语言吧

GMT+8, 2022-12-5 00:13 , Processed in 0.262370 second(s), 38 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表