易语言吧

 找回密码
 立即注册

搜索
热搜: 活动 交友 discuz
查看: 122|回复: 3

[易语言问题] 易语言写好的程序怎么添加账号密码才能登录

[复制链接]

4

主题

58

帖子

276

积分

VIP超级贵宾

Rank: 8Rank: 8

积分
276
威望
0
易币
218
贡献
0
积分
276
UID
18265
在线时间
18 小时
注册时间
2021-9-5
发表于 2022-1-10 13:50:04 | 显示全部楼层 |阅读模式
1易币
易语言写好的程序怎么添加账号密码登录

297

主题

528

帖子

1万

积分

超级版主

Rank: 8Rank: 8

积分
11451

幽默大师终生成就

威望
0
易币
10838
贡献
0
积分
11451
UID
580
在线时间
296 小时
注册时间
2019-12-5
发表于 2022-1-10 16:24:43 | 显示全部楼层
用网络验证
回复

使用道具 举报

3

主题

60

帖子

260

积分

易语言学徒

Rank: 3Rank: 3

积分
260
威望
0
易币
200
贡献
0
积分
260
UID
20231
在线时间
23 小时
注册时间
2021-11-16
发表于 7 天前 | 显示全部楼层
用网络验证加在你的程序上面   或者 用本地验证  是免费的
回复

使用道具 举报

2

主题

12

帖子

116

积分

易语言菜鸟

Rank: 2

积分
116
威望
0
易币
104
贡献
0
积分
116
UID
21026
在线时间
8 小时
注册时间
2021-12-10
发表于 6 天前 | 显示全部楼层
.版本 2
.支持库 xplib

.程序集 窗口程序集1

.子程序 __启动窗口_创建完毕

XP风格 (3)
.如果真 (文件是否存在 (取运行目录 () + “\data.ini”) = 假)
    写到文件 (取运行目录 () + “\data.ini”, #配置文件)
.如果真结束

.如果真 (读配置项 (取运行目录 () + “\data.ini”, “SET”, “记住密码”, ) = “1”)
    选择框1.选中 = 真
    编辑框_账号.内容 = 读配置项 (取运行目录 () + “\data.ini”, “USERNAME”, “账号”, )
    编辑框_密码.内容 = 读配置项 (取运行目录 () + “\data.ini”, “PASSWORD”, “密码”, )
.如果真结束


.子程序 _按钮_注册_被单击

_启动窗口.可视 = 假
载入 (_窗口注册, , 真)

.子程序 _按钮2_被单击
.局部变量 密码, 文本型

密码 = 读配置项 (取运行目录 () + “\data.ini”, “PASSWORD”, “密码”, )
信息框 (“账号【” + 编辑框_账号.内容 + “】” + #换行符 + “密码【” + 密码 + “】”, 0, )

.子程序 _按钮_登录_被单击
.局部变量 账号, 文本型
.局部变量 密码, 文本型

是否保存密码 ()
账号 = 读配置项 (取运行目录 () + “\data.ini”, “USERNAME”, “账号”, )
密码 = 读配置项 (取运行目录 () + “\data.ini”, “PASSWORD”, “密码”, )
.如果真 (编辑框_账号.内容 = 账号 且 编辑框_密码.内容 = 密码)
    信息框 (“账号【” + 编辑框_账号.内容 + “】登陆成功!”, 0, “提示”)
    返回 ()
.如果真结束
.如果 (编辑框_账号.内容 ≠ 账号)
    信息框 (“账号不正确,请检查后重新输入!”, #错误图标 + #确认钮, “提示”)
.否则
    .如果 (编辑框_密码.内容 ≠ 密码)
        信息框 (“密码不正确,请检查后重新输入!”, #错误图标 + #确认钮, “提示”)
    .否则

    .如果结束

.如果结束


.子程序 是否保存密码

.如果 (选择框1.选中 = 真)
    写配置项 (取运行目录 () + “\data.ini”, “SET”, “记住密码”, “1”)
.否则
    写配置项 (取运行目录 () + “\data.ini”, “SET”, “记住密码”, “0”)
.如果结束

回复

使用道具 举报

懒得打字嘛,点击右侧快捷回复 【选择右侧内容,快速回复】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|一:站内所有资源均来自互联网收集或用户上传分享,本站不拥有此类资源的版权。 作为网络服务提供者,对转载行为的发生不具备充分的监控能力。但是当版权拥有者提出侵权并出示充分的版权证明材料时,易语言吧负有移除转载作品以及停止继续传播的义务。在满足前款条件下采取移除等相应措施后不为此向原发布人承担违约责任,包括不承担因侵权不成立而给原发布人带来损害的赔偿责任。 用户免费分享产生,如果侵犯了你的权益,联系QQ:3066137757|Archiver|手机版|小黑屋|易语言吧

GMT+8, 2022-1-18 21:29 , Processed in 0.268102 second(s), 27 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表