tracelessnes 发表于 2020-12-29 04:32:25

怎样在循环里判断命令通过后略过通过的命令

.版本 2

.子程序 子程序1
.局部变量 i, 整数型

' i*返回 1或0

.计次循环首 (5, )

    运行控制台程序 (i1)
    .如果真 (c = 0)
      运行 (指令1)
      ' 通过后不再循环里运行这段命令
    .如果真结束

    运行控制台程序 (i2)
    .如果真 (c = 0)
      运行 (指令2)
      ' 通过后不再循环里运行这段命令
    .如果真结束

    运行控制台程序 (i3)
    .如果真 (c = 0)
      运行 (指令3)
      ' 通过后不再循环里运行这段命令
    .如果真结束

    运行控制台程序 (i4)
    .如果真 (c = 0)
      运行 (指令4)
      ' 通过后不再循环里运行这段命令
    .如果真结束

.计次循环尾 ()



有多个线程进入此程序

怎样在循环里判断命令通过后 然后略过通过的命令 不再判断略过的 其他不通过的继续执行


我是新手 发表于 2020-12-29 09:22:49

跳出循环()

tracelessnes 发表于 2020-12-29 22:05:24

我是新手 发表于 2020-12-29 09:22
跳出循环()

意思错了 我想说的是 有几条线程轮流进来 第一条到循环后通过循环里的那一条命令 则后面的线程进入不在执行此命令 循环里的命令继续执行 通过后同上

huanghua8001 发表于 2020-12-30 03:35:25

改变判断的值
页: [1]
查看完整版本: 怎样在循环里判断命令通过后略过通过的命令