易语言吧

 找回密码
 立即注册
搜索
热搜: 活动 交友 discuz
查看: 33|回复: 4

[易语言问题] 大漠多线程窗口绑定崩溃

[复制链接]

10

主题

44

帖子

338

积分

易语言学徒

Rank: 3Rank: 3

积分
338
威望
0
易币
294
贡献
0
积分
338
UID
2396
在线时间
22 小时
注册时间
2020-3-11
发表于 2020-3-24 23:41:16 | 显示全部楼层 |阅读模式
1易币
.版本 2
.支持库 iext
.支持库 spec
.子程序 绑定游戏窗口, 整数型, , 1 成功
.参数 i, 整数型
.局部变量 窗口句柄, 整数型
.局部变量 窗口索引, 整数型
.局部变量 返回值, 整数型

窗口句柄 = 到整数 (超级列表框1.取标题 (i - 1, #窗口句柄))  ' 取游戏窗口句柄
窗口索引 = 超级列表框1.查找表项 (到文本 (窗口句柄), , , #窗口句柄)  ' 取游戏窗口;列表索引
大漠多线程信息 .大漠.解绑 ()
返回值 = 大漠多线程信息 .大漠.绑定Ex (窗口句柄, “normal”, “normal”, “normal”, “”, 0)                  这里出了问题
调试输出 (返回值)
.判断开始 (返回值 = 1)
    绑定状态 = “1”
    超级列表框1.置标题 (窗口索引, #绑定状态, “绑定成功”)
.默认
    超级列表框1.置标题 (窗口索引, #绑定状态, “绑定失败”)
.判断结束
辅助延时 (1314)
返回 (返回值)



我用的是别人的多线程模板 能正常获取句柄 窗口绑定无论什么模式 摁Home键绑定直接崩溃掉了
截图202003242340196515..png 崩溃前是这样的

回复

使用道具 举报

10

主题

44

帖子

338

积分

易语言学徒

Rank: 3Rank: 3

积分
338
威望
0
易币
294
贡献
0
积分
338
UID
2396
在线时间
22 小时
注册时间
2020-3-11
 楼主| 发表于 2020-3-24 23:42:28 | 显示全部楼层
发问题的字体好像有点问题。。突然变了
回复

使用道具 举报

16

主题

34

帖子

1537

积分

版主

Rank: 7Rank: 7Rank: 7

积分
1537
威望
0
易币
1503
贡献
0
积分
1537
UID
4
在线时间
18 小时
注册时间
2019-7-24
发表于 2020-3-25 10:19:21 | 显示全部楼层
窗口句柄为0吧.你调试下看看是多少
回复

使用道具 举报

0

主题

3

帖子

13

积分

初识易语言

Rank: 1

积分
13
威望
0
易币
10
贡献
0
积分
13
UID
2859
在线时间
0 小时
注册时间
2020-3-23
发表于 2020-3-25 11:42:21 | 显示全部楼层
新手学习学习
回复

使用道具 举报

10

主题

44

帖子

338

积分

易语言学徒

Rank: 3Rank: 3

积分
338
威望
0
易币
294
贡献
0
积分
338
UID
2396
在线时间
22 小时
注册时间
2020-3-11
 楼主| 发表于 2020-3-26 21:24:29 | 显示全部楼层
易辈子 发表于 2020-3-25 10:19
窗口句柄为0吧.你调试下看看是多少

弄了几天发现是没注册vip 原来用别的模块也是要注册 因为都是用到大漠插件。。
回复

使用道具 举报

懒得打字嘛,点击右侧快捷回复 【选择右侧内容,快速回复】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|一:站内所有资源均来自互联网收集或用户上传分享,本站不拥有此类资源的版权。 作为网络服务提供者,对转载行为的发生不具备充分的监控能力。但是当版权拥有者提出侵权并出示充分的版权证明材料时,易语言吧负有移除转载作品以及停止继续传播的义务。在满足前款条件下采取移除等相应措施后不为此向原发布人承担违约责任,包括不承担因侵权不成立而给原发布人带来损害的赔偿责任。 用户免费分享产生,如果侵犯了你的权益,联系QQ:3066137757|Archiver|手机版|小黑屋|易语言吧  

GMT+8, 2020-4-5 12:24 , Processed in 0.319009 second(s), 32 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表